白姐透特今晚开什么码

打印

[技术问答]新开一个帖子 经过几天的调试 电机终于转了,但是

[复制链接]
531|15
跳转到指定楼层
楼主
新开一个帖子  经过几天的调试  电机终于转了,但是   波形 始终不怎么完美  上下尖 过于大  无论栅极电阻如何调整 均不理想  不知道该如何处理.  而且出现尖 还很有规律

1.jpg(298.64 KB, 下载次数: 3)

1.jpg

2.jpg(315.52 KB, 下载次数: 3)

2.jpg

3.jpg(319.12 KB, 下载次数: 3)

3.jpg

相关资料

沙发
|2019-12-18 15:50|只看该作者
你开同步模式了是吧,这很显然,是死区开大了。才出现这样的情况,记得你选择的驱动芯片好像自己带的死区,你输出程序里面,可以去掉所有死区参数,直接互补输出,就会正常。
波形很好,我们说的尖峰是指方波的上升沿会带上一个尖峰,下降沿会带上一个比较难看的反向尖峰。至于栅极电阻,恢复到100欧姆级别吧。
板凳
 楼主|2019-12-18 20:17|只看该作者
好的   一直以为  死区时间大 只会降低效率,想不到还会干扰波形.  明天 继续试验.  我的芯片死区是200ns  不知道 是否够不够?  
地板
|2019-12-18 20:24|只看该作者
调节试试,这些参数都设置成可调的,然后连续调整观察观察。
5
|2019-12-19 09:07|只看该作者
cub_wolf 发表于 2019-12-18 20:17
好的   一直以为  死区时间大 只会降低效率,想不到还会干扰波形.  明天 继续试验.  我的芯片死区是200ns   ...

死区如果不够可以在程序互补死区里面加啊,每单位62.5nS,肯定能调整到合适的,一般来说,死区和输入电压高低、栅极驱动能力有影响,栅极恢复正常驱动参数,在100来V范围,芯片的200nS死区就完全够了,查看死区是不是够,你可以在其中一个MOS管回路串联一个小电阻,测量该小电阻2端电压就可以明确,如果发生共通,因为该时刻,所有电压都会加在这个串联的小电阻上面,所以电阻上面会有开关边沿很高的电压出现(注意排除感应尖峰影响)。
6
 楼主|2019-12-19 09:48|只看该作者
tianxj01 发表于 2019-12-19 09:07
死区如果不够可以在程序互补死区里面加啊,每单位62.5nS,肯定能调整到合适的,一般来说,死区和输入电压 ...

好的  我只是不明白 死区 和那个冲上来的尖锐波形 有啥关系
7
 楼主|2019-12-19 10:38|只看该作者
本帖最后由 cub_wolf 于 2019-12-19 10:40 编辑

现在将死区调整到1个US,上下 稍微有贯通的情况 而且 我发现 无论如何处理 那个尖 总是冲到4V多

4.jpg(313.72 KB, 下载次数: 3)

4.jpg

5.png(614.36 KB, 下载次数: 3)

5.png
8
|2019-12-19 10:50|只看该作者
cub_wolf 发表于 2019-12-19 09:48
好的  我只是不明白 死区 和那个冲上来的尖锐波形 有啥关系

很典型的,由于寄生电容的影响,栅极驱动信号通过寄生电容对尚未导通的桥臂中点耦合造成,由于死区过大,所以管子都截止,这就产生了这样尖峰,看起来很不舒服,其实对工作无害。
9
 楼主|2019-12-19 10:56|只看该作者
总是有些贯通  不知道如何 消除 那个4V的尖  至少 要控制在1V以里
10
|2019-12-19 11:07|只看该作者
本帖最后由 tianxj01 于 2019-12-19 11:11 编辑
cub_wolf 发表于 2019-12-19 10:38
现在将死区调整到1个US,上下 稍微有贯通的情况 而且 我发现 无论如何处理 那个尖 总是冲到4V多
...

这个不是贯通,是典型的米勒平台+驱动通过杂散电容干扰导致的波形。观察上下臂直通,必须串联小电阻到上臂的D--VCC之间,测量该电阻2端电压。有直通,则表现出到VCC的导通电压。而且,部分采用栅极深沟槽工艺的管子,自己就会在米勒平台产生一个类似的震荡波,在VCC为高压时候,很常见,不过低压一般是由驱动耦合造成。
11
 楼主|2019-12-19 11:27|只看该作者
tianxj01 发表于 2019-12-19 11:07
这个不是贯通,是典型的米勒平台+驱动通过杂散电容干扰导致的波形。观察上下臂直通,必须串联小电阻到上臂 ...

问题是 不管是什么原因 导致的这东西出现,现在是电流变很大  把电压瞬间拉下来  然后 停机  
12
|2019-12-19 11:29|只看该作者
cub_wolf 发表于 2019-12-19 11:27
问题是 不管是什么原因 导致的这东西出现,现在是电流变很大  把电压瞬间拉下来  然后 停机   ...

你栅极驱动参数恢复了没?
否则1uS死区,是不可能导致电流变很大的。
13
 楼主|2019-12-19 11:33|只看该作者
tianxj01 发表于 2019-12-19 11:29
你栅极驱动参数恢复了没?
否则1uS死区,是不可能导致电流变很大的。

和这个图的参数是一模一样的

5.png(614.36 KB, 下载次数: 3)

5.png
14
|2019-12-19 15:26|只看该作者
cub_wolf 发表于 2019-12-19 11:33
和这个图的参数是一模一样的

把上管栅极、下管栅极、桥臂中心这三者波形一起三踪贴出看看吧。
这类线路,栅极参数68Ω,1uS开始共通是不应该的。
15
|2019-12-19 22:39|只看该作者
R10和R23去掉,再试试?
16
|2019-12-21 10:05|只看该作者
转动的完美吗
扫描二维码,随时随地手机跟帖

本版积分规则

我要发帖投诉建议创建版块

快速回复

您需要登录后才可以回帖
登录 | 注册

论坛热帖

在线客服 快速回复 返回顶部返回列表